信息搜索与浏览器配置

搜索

hppts/http 443/80 https传输层tcp端口(443)

物联网 移动互联 大数据 智慧城市 vr 区块链 DT

浏览器配置

url (域名地址) 标题栏 浏览区 internet选项

域名地址

开始|运行|cmd ipconfig

网络参数: ip address IP地址

subnet mask 子网掩码
Default Gateway 网关
DNS server DNS服务器
ip 地址(进制转换 二进制转十进制 )

通过IP地址访问网络,域名依靠于IP地址,如果IP地址出现问题,域名地址将无法访问!

IP本质属于32个二进制位,ip地址用来表示网络中的设备,32个二进制人并不好识别,所以就用小圆点

将二进制分割成四部分,每部分都是八个二进制位,范围是:0~255

物理地址 MAC 地址(进制转换 二进制转十六进制)

MAC

http与https的区别

http访问的时候是www服务器,遵守http协议(传输层的TCP端口80)

https访问的也是www服务器,遵守安全协议的http协议(端口443)

二进制
### 二进制 十进制

---------------------------------

00 0 0 00 0 0 0

00 0 0 00 0 1 1

00 0 0 00 1 0 2

00 0 0 00 1 1 3

00 0 0 01 0 0 4

00 0 0 01 0 1 5

00 0 0 01 1 0 6

00 0 0 01 1 1 7

00 0 0 10 0 0 8

00 0 0 10 0 1 9

00 0 0 10 1 0 10

00 0 0 10 1 1 11

00 0 0 11 0 0 12

00 0 0 11 0 1 13

00 0 0 11 1 0 14

00 0 0 11 1 1 15

00 0 1 00 0 0 16

00 0 1 00 0 1 17

00 0 1 00 1 0 18

。。。。。。。。。。。。

11 1 1 11 1 0 254

11 1 1 11 1 1 255

数字范围 0~255

ip

0是标志位

IP地址与子网掩码

0 0 0

0 0 1

0 1 0

0 1 1

1 0 0

1 0 1

1 1 0

1 1 1

作业

192.168.1.0 此ip判定为c类地址 c类IP默认掩码为255.255.255.0

子网个数是三个,借用的主机位数为二位

ip计算

一个 0或者1

两个 00 01 10 11 4种

三个 000 001 010 011 100 101 110 111 8种

四个 0000 0001 0010 0011 0100 0101 0110 0111

1000 1001 1010 1011 1100 1101 1110 1111 16种

划分三个子网 必须确定新的子网掩码

项目上的写法为 IP地址

192.168.1.0/24 24表示子网掩码1的位数为24

新掩码 192.168.1.0/24+2 即192.168.1.0/26

第一个子网:192.168.1.0 0

主机地址为0就是网络地址

主机地址为1就是广播地址

128 64 32 16 8 4 2 1

192.168.1.0 0 00 00 00

192.168.1.0 0 00 00 01

192.168.1.0 0 00 00 10

........

192.168.1.0 0 11 11 10

192.168.1.0 0 11 11 11

第二个子网:192.168.1.0 1

128 64 32 16 8 4 2 1

192.168.1.0 1 00 00 00 ** 网络地址

192.168.1.0 1 00 00 01

192.168.1.0 1 00 00 10

192.168.1.0 1 00 00 11

192.168.1.0 1 00 01 00

192.168.1.0 1 00 01 01

192.168.1.0 1 00 01 10

192.168.1.0 1 00 01 11

192.168.1.0 1 00 10 00

192.168.1.0 1 00 10 01

192.168.1.0 1 00 10 10

192.168.1.0 1 00 10 11

192.168.1.0 1 00 11 00

192.168.1.0 1 00 11 01

192.168.1.0 1 00 11 10

192.168.1.0 1 00 11 11

192.168.1.0 1 01 00 00

192.168.1.0 1 01 00 01

192.168.1.0 1 01 00 10

192.168.1.0 1 01 00 11

192.168.1.0 1 01 01 00

192.168.1.0 1 01 01 01

192.168.1.0 1 01 01 10

192.168.1.0 1 01 01 11

192.168.1.0 1 01 10 00

192.168.1.0 1 01 10 01

192.168.1.0 1 01 10 10

192.168.1.0 1 01 10 11

192.168.1.0 1 01 11 00

192.168.1.0 1 01 11 01

192.168.0.1 1 01 11 10

192.168.0.1 1 01 11 11

192.168.0.1 1 10 00 00

192.168.0.1 1 10 00 01

192.168.0.1 1 10 00 10

192.168.0.1 1 10 00 11

192.168.0.1 1 10 01 00

192.168.0.1 1 10 01 01

192.168.0.1 1 10 01 10

192.168.0.1 1 10 01 11

192.168.0.1 1 10 10 00

192.168.0.1 1 10 10 01

192.168.0.1 1 10 10 10

192.168.0.1 1 10 10 11

192.168.0.1 1 10 11 00

192.168.0.1 1 10 11 01

192.168.0.1 1 10 11 10

192.168.0.1 1 10 11 11

192.168.0.1 1 11 00 00

192.168.0.1 1 11 00 01

192.168.0.1 1 11 00 10

192.168.0.1 1 11 00 11

192.168.0.1 1 11 01 00

192.168.0.1 1 11 01 01

192.168.0.1 1 11 01 10

192.168.0.1 1 11 01 11

192.168.0.1 1 11 10 00

192.168.0.1 1 11 10 01

192.168.0.1 1 11 10 10

192.168.0.1 1 11 10 11

192.168.0.1 1 11 11 00

192.168.0.1 1 11 11 01

192.168.0.1 1 11 11 10

192.168.0.1 1 11 11 11 广播地址

第三个子网:192.168.1.1 0

192.168.1.1 0 00 00 00 网络地址

192.168.1.1 0 00 00 01

192.168.1.1 0 00 00 10

192.168.1.1 0 00 00 11

192.168.1.1 0 00 01 00

192.168.1.1 0 00 01 01

192.168.1.1 0 00 01 10

192.168.1.1 0 00 01 11

192.168.1.1 0 00 10 00

192.168.1.1 0 00 10 01

192.168.1.1 0 00 10 10

192.168.1.1 0 00 10 11

......

192.168.1.1 0 11 11 10

192.168.1.1 0 11 11 11 广播地址

128 64 32 16 8 4 2 1

1 1 1 1 0 0 0 0

128+64+32+16 240

即IP范围就是 192.168.1.01000001 ~ 192.168.1.01111110

转换为十进制 192.168.1.65 ~ 192.168.1.126

新的子网掩码 255.255.255.11110000

255.255.255.240

子网计算方式:

必须使用2的次方来计算,计算结果必须大于等于子网位数,

如果子网位数为3,那必须使用2的2次方来计算,即2的2次方=4 4>3

255.255.255.11000000

128 64 32 16 8 4 2 1

1 1 0 0 0 0 0 0

128+64=192

255.255.255.192

划分15个子网,即2的4次方=16 16>15

255.255.255.11110000

128 64 32 16 8 4 2 1

1 1 1 1 0 0 0 0

128+64+32+16=240

255.255.255.240

第四个子网:192.168.1.1 1

192.168.1.1 1 00 00 00 网络地址

192.168.1.1 1 00 00 01

192.168.1.1 1 00 00 10

192.168.1.1 1 00 00 11

192.168.1.1 1 00 01 00

192.168.1.1 1 00 01 01

192.168.1.1 1 00 01 10

192.168.1.1 1 00 01 11

192.168.1.1 1 00 10 00

192.168.1.1 1 00 10 01

192.168.1.1 1 00 10 10

192.168.1.1 1 00 10 11

192.168.1.1 1 00 11 00

192.168.1.1 1 00 11 01

192.168.1.1 1 00 11 11

192.168.1.1 1 01 00 00

......

192.168.1.1 1 11 11 10

192.168.1.1 1 11 11 11 广播地址

即ip范围就是 192.168.1.10000001 ~ 192.168.1.10111110

转换为十进制 192.168.1.129 ~ 192.168.1.190

1

ip地址+子网掩码,合起来确定一个网络设备

一个ip只能分配一个设备,如果一样,则会造成ip地址冲突

cisco

console 控制线 带外管理

console线,pc连接的是com口 设备端是console口 (控制线)

copper Straight-Through (黑色)标准网线

Copper Cross-Over (黑色短截) 交叉网线

fiber (橙色)的是光纤

DCE 需要配置时钟频率(终端连接设备)

DTE 数据终端设备

交换机路由器等网络设备 通常使用专用的console线连接设备的console口,另一端连接pc的com口 通过带外管理方式来与设备通信,并且管理设备

交换机的基本配置

配置名称

en (提权)

hostname (更改后名称)

config t

no ip domain-lookup

hostname mingcheng

交换机管理IP配置

interface vlan 1

交换机的ip地址在interface val 1

ipaddress 192.168.7.100 255.255.255.0

no shutdown

交换机的验证

Running-config 保存的是实时文件,掉电丢失

Startup-config 保存的是非实时文件,掉电不丢失

交换机启动时按照 Startup-config 配置文件启动交换机,执行力保存操作,就看到了保存的配置文件

10.1.10/30 255.255.255.111111000

路由器的不同接口可以配置不同的ip地址(连接不同的网段)

一个路由器中的一个接口可以配置一个ip地址

路由器配置命令

config t

int f0/0

ip add 192.168.1.1 255.255.255.0

no shutdown

write 写入保存

路由器基本认识

Ethernet 以太网

Fast Ethernet 快速以太网

12/1

如果没有特别配置 交换机的配置文件都在vlan里面

划分vlan方法

yang2#show vlan

yang2#conf t

yang2(config)#vlan 100

yang2(config-vlan)#ex

yang2(config)#ex

yang2#show vlan

交换机的三种模式

yang2(config-if)#switchport mode ?

access Set trunking mode to ACCESS unconditionally

dynamic Set trunking mode to dynamically negotiate access or trunk mode

trunk Set trunking mode to TRUNK unconditionally

yang1

yang1#conf t

Enter configuration commands, one per line. End with CNTL/Z.

yang1(config)#int f0/11

yang1(config-if)#swit

yang1(config-if)#switchport mode

yang1(config-if)#switchport mode access

yang1(config-if)#switchport access ?

vlan Set VLAN when interface is in access mode

划分端口 11 13 15到vlan300

yang1(config)#interface range fa 0/11,fa0/13,fa0/15

yang1(config-if-range)#switchport access vlan 300

yang1(config-if-range)

no [任何命令,取消]

路由器协议配置

路由:静态路由

ip route 172.16.87.0 255.255.255.0 s1/3

目标网段 目标网段子网掩码 下一跳接口

ip route 172.16.87.0 255.255.255.0 10.1.4.1

目标网段 目标网段子网掩码 下一跳ip

路由:动态路由

rip1 协议

router rip

network 旁边设备ip

rip2 协议

router rip

network 旁边设备ip

查看rip命令

show ip route

数据在不同的层 名称不一样

Frame 帧 在网络接口层

Ethernet Ⅱ Src Dst MACAddress 物理地址

InternetProtocol Version 4 网络层 Src Dst 都是ip地址

User Datagram Protocol 用户数据报协议 传输层协议 SrcPort 源端口 Dst port 目标端口

Hypertext Transfer Protocol 超文本传输协议

传输介质 网络接口层 网际层 传输层 应用层

抓取并分析ipv4数据协议

ipv4 是一个网际层的协议

这个数据在传输层遵守的协议是udp

比较重要的协议包括为 ipv4 tcp udp

交换机端口安全

switchport port-security ?

mac-address Secure mac address

maximum Max secure addresses

violation Security violation mode

建网

网卡 NIC network Interface Card

双绞线网卡 AUI网卡(细同轴电缆以太网)

BNC网卡 (粗同轴电缆以太网)

光纤网卡

双绞线网卡连接的网线是目前最常见的,用的标准网线

网线:标准网线

交叉网线

console 控制线

标砖网线:线序

B 白橙 橙 白绿 蓝 白蓝 绿 白棕 棕

B 白橙 橙 白绿 蓝 白蓝 绿 白棕 棕

12345678

12345678

交叉网线:线序

A 白绿 绿 白橙 蓝 白蓝 橙 白棕 棕

B 白橙 橙 白绿 蓝 白蓝 绿 白棕 棕

12345678

36145278

控制线:交换机、路由器等网络设备自带的特殊专用线

网卡:在局域网中,网卡可以接受到所有internet数据流

在 wireshark 等抓包软件工具中,让网卡工作在混杂模式,就可以抓取到局域网的所有数据

不同厂商的设备的控制线不能混用

交换机:switch 功能:地址学习(学习的是所连端口地址,物理原地址)

地址表:端口24(48)地址:(源端口的物理地址)

数据转发或者过滤

避免环路(通过stp生成树协议)

配置:管理IP地址

VLan 与端口

连接的是传输介质相同的网络

路由器 router

   连接 LAN 与LAN,LAN 与 WAN WAN 与 WAN

网关 gateway 

   连接不同协议的网络

WLAN 与 WiFi

无线路由器 配置 pc--标准网线--无线路由器(SSID)

建网的技能:网线制作与测试

双PC机互联,组建对等网,实现资源共享

WLAN

管网:

1.网络服务 访问 Internet

网卡 (有线网卡、无线网卡)

协议 (TCP/IP)

网络参数设置 IP Address、Subnet mask、Default Gateway 、DNS Server

ip地址 子网掩码 网关 DNS服务器

局域网Internet 要有网络接口和internet联通

测试操作:ipconfig 看ip地址 要上网,pc必须配置ip

ping 自己ip 测试自己网络是否联通

ping 网关 查看网关是否联通

2.网络硬件资源

Switch、Router、Firewall、IPS、IDS、WAF、Netlog

根据设备手册,CLI 配置命令或者GUI图形化界面

3.网络软件资源:服务器

www.baidu.com WWW 服务器

mail.163.com SMTP服务器 发送

POP3服务器 接受

FTP://172.16.2.100 FTP服务器

4.网络用户上网权限管理、上网行为管理

5.云平台搭建与运维

linux系统

OpenStack 平台

Docker 运维

Shell 编程

6.网络命令

ipconfig ping net tracert arp netstat Netscape netsc

最后修改:2021 年 02 月 28 日 11 : 46 PM
如果觉得我的文章对你有用,请随意赞赏